Results 1 to 3 of 3

Thread: Need help configuring BCM5709C with 802.3ad on Cisco switch

  1. #1
    Junior Member
    Join Date
    Apr 2012
    Posts
    2

    Need help configuring BCM5709C with 802.3ad on Cisco switch

    I already opened a TAC case with Cisco and they say the problem is on the server side. If I set the switch physical interfaces to 'mode active' then the server can connect to the LAN on all teamed adapters, but the channel & port status show that it is not bundling the ports correctly. If we set the switch physical interfaces to 'mode on' then the channel & port status show the correct bundling but the server cannot connect to the LAN.

    Here are the applicable switch settings:

    !
    interface Port-channel1
    description Yardi database server (g3/0/8, g3/0/33 & g2/0/21)
    switchport access vlan 10
    switchport mode access
    !
    interface GigabitEthernet2/0/21
    description Yardi database server embedded port 1 (left) (teamed with switch port g3/0/33 & g3/0/8)
    switchport access vlan 10
    switchport mode access
    no snmp trap link-status
    channel-group 1 mode active
    spanning-tree portfast
    !
    interface GigabitEthernet3/0/8
    description Yardi database server NIC port 0 (top) (teamed with switch port g3/0/33 & g2/0/21)
    switchport access vlan 10
    switchport mode access
    no snmp trap link-status
    channel-group 1 mode active
    spanning-tree portfast
    !
    interface GigabitEthernet3/0/33
    description Yardi database server NIC port 1(bottom) (teamed with switch port g3/0/8 & g2/0/21)
    switchport access vlan 10
    switchport mode access
    no snmp trap link-status
    channel-group 1 mode active
    spanning-tree portfast
    !

    HQ-CORE-3750-STACK#sh etherchannel 1 detail
    Group state = L2
    Ports: 3 Maxports = 16
    Port-channels: 1 Max Port-channels = 16
    Protocol: LACP
    Ports in the group:
    -------------------
    Port: Gi2/0/21
    ------------

    Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl <------------------------------------------
    Channel group = 1 Mode = Active Gcchange = -
    Port-channel = null GC = - Pseudo port-channel = Po1
    Port index = 0 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
    A - Device is in active mode. P - Device is in passive mode.

    Local information:
    LACP port Admin Oper Port Port
    Port Flags State Priority Key Key Number State
    Gi2/0/21 SA indep 32768 0x1 0x1 0x4B 0x7D

    Age of the port in the current state: 0d:04h:12m:26s

    Port: Gi3/0/8
    ------------

    Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl <-----------------------------------------
    Channel group = 1 Mode = Active Gcchange = -
    Port-channel = null GC = - Pseudo port-channel = Po1
    Port index = 0 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
    A - Device is in active mode. P - Device is in passive mode.

    Local information:
    LACP port Admin Oper Port Port
    Port Flags State Priority Key Key Number State
    Gi3/0/8 SA indep 32768 0x1 0x1 0x74 0x7D

    Age of the port in the current state: 0d:04h:12m:33s

    Port: Gi3/0/33
    ------------

    Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl <---------------------------------------------
    Channel group = 1 Mode = Active Gcchange = -
    Port-channel = null GC = - Pseudo port-channel = Po1
    Port index = 0 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
    A - Device is in active mode. P - Device is in passive mode.

    Local information:
    LACP port Admin Oper Port Port
    Port Flags State Priority Key Key Number State
    Gi3/0/33 SA indep 32768 0x1 0x1 0x8D 0x7D

    Age of the port in the current state: 0d:04h:12m:25s

    Port-channels in the group:
    ---------------------------

    Port-channel: Po1 (Primary Aggregator)

    ------------

    Age of the Port-channel = 1d:00h:22m:53s
    Logical slot/port = 10/1 Number of ports = 0
    HotStandBy port = null
    Port state = Port-channel Ag-Not-Inuse <-------------------------------------------------------
    Protocol = LACP

    Time since last port bundled: 0d:04h:14m:29s Gi3/0/33
    Time since last port Un-bundled: 0d:04h:12m:30s Gi3/0/33

    HQ-CORE-3750-STACK#sh etherchannel load-balance
    EtherChannel Load-Balancing Configuration:
    src-mac

    EtherChannel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: Source MAC address
    IPv4: Source MAC address
    IPv6: Source MAC address

    HQ-CORE-3750-STACK#

    In BACS4, the team link status is up, but BASP state on 2 of the 3 NIC ports is 'not active'. Driver version is 6.2.9.0, dated 5/24/2011.

    How do I properly configure LACP between these Broadcom adapters and the Cisco switch?

  2. #2
    Broadcom Corporation Dave's Avatar
    Join Date
    May 2011
    Posts
    357
    Quote Originally Posted by JimM View Post
    In BACS4, the team link status is up, but BASP state on 2 of the 3 NIC ports is 'not active'. Driver version is 6.2.9.0, dated 5/24/2011.
    Sorry, don't know the Cisco IOS command-line so I can't offer any help there. I've setup LACP through the GUI on Dell switches and haven't encountered a problem.

    You mention BACS4, which is a relatively recent release, in the same sentence as an older driver. Can you update to the latest drivers on the Broadcom web site (http://www.broadcom.com/support/ethe...etxtremeii.php) as well? I don't know that this is related but it's always best to use software all from the same release. I'm assuming that's where you got the BACS4 release.

    There aren't any configurable settings on the server side for LACP, configuration frames come down from the switch so we're essentially a slave when LACP is enabled. You mention "BASP state" is "not active" above. Does this come from the switch of from BACS on the server?

    Dave

  3. #3
    Junior Member
    Join Date
    Apr 2012
    Posts
    2
    Hi Dave,

    Sorry for the delayed response, I didn't realize I needed to manually add a subscription to a thread I started. The drivers I referenced in the original post are the latest ones in IBM's UpdatExpress mechanism. After I posted this I tried the latest Broadcom drivers (version 7.0.11.0) but no change. Ironically I'm almost done wading through the IBM software support gauntlet.

    "BASP state" not active is being reported by the BACS console. It appeared to me that the BACS I downloaded was the latest version; if it's not, do you have a link to the most recent version? The application itself says BACS4, version 15.0.30.0, which seems confusing.

    Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •